Perforce Public Knowledge Base - How To Identify P4VS
Reset Search
 

 

Article

How To Identify P4VS

« Go Back

Information

 
Problem

How do I identify if the P4VS plug-in is installed with Visual Studio? Sometimes this may be confused with a different SCM plug-in.

Solution

P4VS uses Microsoft .NET instead of the Microsoft SCC API that P4SCC uses. As a result of P4VS using Microsoft .NET instead, P4VS has deeper integration with the IDE and we now can use our own Perforce dialogs.

There are several ways to identify if the P4VS plug-in is installed with Visual Studio. Here is a list of items to look for along with an overview of the dialogs and menus.

Installation and Version

If Visual Studio 2008 is not being used, go to Help -> About Microsoft Visual Studio. Notice under Installed Products that P4VS - Perforce Plugin for Visual Studio is listed.  Note that non-Perforce plugins may also be listed.

kA0F0000000Cq64KAC_en_US_4_0


In Visual Studio 2008, choose File, Open Connection to a Perforce Depot, and
look in the bottom left corner.  Here we see the 2013.2.70.6702 version of P4VS.

kA0F0000000Cq64KAC_en_US_4_1

The older Perforce P4SCC plugin may also have been installed.  In general, mixing P4VS and P4SCC is not recommended.  To check if the P4SCC plug-in is installed, go to Visual Studio -> Tools-> Options -> Source Control -> Plug-in Selection, and click the dropdown under Current source control plugin on the right pane.

 

Plug-In Selection

To confirm that P4VS is the current source control plug-in in Visual Studio 2010.

  • In Visual Studio 2010, go to the menu Tools -> Options
  • Under Options go to Source Control -> Plug-in Selection
  • Make sure you see selected in the drop-down box:

    P4VS - Perforce Plugin for Visual Studio

kA0F0000000Cq64KAC_en_US_4_2

 

 

Installer

Run the p4vs.exe installer again.  Click Modify -> Versions and check the version string

kA0F0000000Cq64KAC_en_US_4_3

 

 

P4VS Examples

Below are sample Perforce dialog boxes.

 

File -> Source Control menu

Under the menu File -> Source Control for an open project, will look as follows

kA0F0000000Cq64KAC_en_US_4_4

 

Check Out Files

The dialog to Check Out files looks as follows:

kA0F0000000Cq64KAC_en_US_4_5

 

Get Revision

The dialog to get a revision (sync) looks as follows

kA0F0000000Cq64KAC_en_US_4_6

 

Context Menu

The general P4VS context menu options appear as follows. Notice options such as Mark for Add to Diff and Views.

kA0F0000000Cq64KAC_en_US_4_7

 

Submit Dialog

When submitting files the user sees the following dialog.

kA0F0000000Cq64KAC_en_US_4_8

 

View Menu

The View menu shows the following options, such as Workspaces, File History, Jobs, Submitted Changelists and Pending Changelists.

kA0F0000000Cq64KAC_en_US_4_9

 

View Workspace

The P4VS Workspaces dialog is as follows

kA0F0000000Cq64KAC_en_US_4_10

 

View Jobs

The P4VS Jobs dialog is as follows

kA0F0000000Cq64KAC_en_US_4_11

 

View History

The P4VS History dialog is as follows

kA0F0000000Cq64KAC_en_US_4_12

 

View Pending Changes

The P4VS dialog to view pending changelists looks as follows.

kA0F0000000Cq64KAC_en_US_4_13

 

View Submitted Changes

The P4VS Submitted changelists dialog is as follows

kA0F0000000Cq64KAC_en_US_4_14

 

 

Related Links

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255